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1 Installing the VETtrak APIs onto IIS 7 or Later

This document describes how to install the ASP.NET VETtrak APIs onto a Microsoft Internet Information
Services 7 (on Windows Vista or Server 2008), 7.5 (on Windows 7 or Server 2008 R2), 8 or 8.1 (on Windows 8
or Server 2012) server, and how to configure it to run.

11 Step 1- Install/Check IIS 7, 7.5, 8 or 8.5

Ensure that the .NET Framework version 3.5, .NET Framework version 2.0 with at least Service Pack 2, and
Internet Information Services (1IS) 7 or later is installed on the server machine. At a minimum, the IIS
Management Console and ASP.NET components (which will automatically include its dependencies such as
.NET Extensibility, ISAPI Extensions and ISAPI Filters) must be installed. Additional 1IS features may be
installed if desired, but are not required by the VETtrak APIs.

1.1.1 Windows Vista or Windows 7

In Windows Vista / 7, IIS can be installed or the installation checked by going to Start > Control Panel >
Programs and Features > Turn Windows Features on or off:

Windows Features l_l_l_J‘:' (5] > -

Turn Windows features on or off (7]

To turn a feature on, select its check box, To turn a feature off, clear its
check box. A filled box means that only part of the feature is turned on.

= Internet Information Services -
@ [C] |, FTP Publishing Service
= [E | Web Management Toals
m [ 1) 156 Management Cornpatibility
[¥] .. TS Management Console
[C] |, OS Management Scripts and Tools
[] | OS Management Service
o [ | World Wide Web Services
= [ || Application Developrment Features
& .NET Extensibility
[l Asp
I /

[¥] | ISAPI Extensions

(] I, ISAPI Filters
[] || Server-Side Includes

m

i

= [@ | Common Http Features

@ [H | Health and Diagnostics

, Performance Features

3] Security =

QK ] [ Cancel
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1.1.2

Windows 8 or 8.1

In Windows 8 or 8.1, IS can be installed or the installation checked by opening the Control Panel, then opening

Programs and Features and clicking Turn Windows features on or off:

=

Turn Windows features on or off

reans that only part of the feature is turned on.

Windows Features

O

To turn a feature on, select its checkbox. To turn a feature off, clear its checkbox. A filled box

(7]

= [=] |, Internet Information Services
[]!, FTP Server
= =]} Web Management Tools
L[] 1) IS 6 Management Compatibility
) 115 Management Console
[] 1. IS Management Scripts and Tools
[ ] IS Management Service
= [w] | World Wide Web Services
= [=] |, Application Development Features
. MET Extensibility 3.5
. MET Extensibility 4.5
 Application Initialization
| ASP
, ASPMET 3.5
, ASP.MET 4.5
, Cal
| ISAPI Extensions
| ISAPI Filters
| Server-Side Includes
WebSocket Protocol

; Common HTTP Features

DORROOROOHE

Cancel
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1.1.3 Windows Server 2008

In Windows Server 2008, 1IS can be installed or the installation checked by going to Start > Control Panel >

Administrative Tools > Server Manager > Roles, and adding or editing the Web Server (IIS) role:

Add Role Services

i

Role Services

Confirmation
Progress

Results

' %i Select Role Services

Select the role services to install for Web Server (I1S):
Role services:

= [E web Server (Installed)
|E common HTTP Features (Installed)
= [E application Development (Installed)

15 rs (Instal
[] server Side Indudes
[] Health and Diagnostics
[E security (Installed)
[] Performance
= [E Management Tools (Installed)
115 Management Console (Ir l=d)
[] 115 Management Scripts and Tools
E Management Service
[] 115 6 Management Compatibility
[] FTP Publishing Service

More about role services

< Previous

MeExt>

Description:

ASP.MET provides a server side object
oriented programming environment
forbuilding Web sites and Web
applications usingmanaged code.
ASP.MET is not simply a new version
of ASP. Having been entirely re-
architected to provide a highly
productive programming experience
based on the .NET Framework,
ASP.MET provides a robust
infrastructure for building web
applications.

%]

© 2015 VETtrak Pty Ltd



6 Installing the ASP.NET VETtrak API onto IIS 7 or Later

1.1.4 Windows Server 2008 R2
In Windows Server 2008 R2, 11S can be installed or the installation checked by going to Start > Control Panel >

Administrative Tools > Server Manager > Roles, and adding or editing the Web Server (lIS) role:

Add Roles Wizard

F
! Select Role Services

Before You Begin

Select the role services toinstall for Web Server (1151

Description:

Server Roles Role services:
Web Server (115) = [0 web Server
# [@E Common HTTP Features
] : = [E application Development
Confirmation il
Progress [] MET Extensibility
Resulks IT A3k
[] car
[¥] 154PI Extensions
[] 15AP1 Filters
[ server Side Includes

7 [E Management Tools

# [E Health and Diagnostics
H @ security
= [@ Performance

[ﬁ 115 Management Console

applications.

[] 115 Management Scripts and Tools

|: Management Service

M [ 115 6 Management Compatibilicy
= [] FTP Server

[] 115 Hostable Web Core

More about role services

% Previous | Mext = I Irskall

ASPLMET provides a server side object
otiented programming environment
fFor building \Web sites and Web
applications using managed code.
ASPMET is nok simply & new version
of ASP, Having been entirely re-
architected to provide a highly
productive programming experience
based on the .MET Framewark,
ASP.MET provides a robust
infrastructure For building web

Cancel
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1.1.5 Windows Server 2012 or 2012 R2

In Windows Server 2012 or 2012 R2, |IS can be installed by opening the Server Manager, going to the “Manage”
menu, selecting “Add Roles and Features”, and adding the Web Server (IIS) role. For details, refer to http://
www.iis.net/learn/get-started/whats-new-in-iis-8/installing-iis-8-on-windows-server-2012 .

[ Add Roles and Features Wizard \;Ii-

[

DESTIMATION SERVER

Select server roles

Select one or more roles to install on the selected server.

Roles Description

A ‘Web Server (|IS) provides a reliable, manageable, and scalable

P [H] File and Storage Services (3 of 12 installed) T : -
eb application infrastructure.

[] Hyper-v
[ Metwork Policy and Access Services

[] Print and Document Services

[] Remate Access

[] Remote Desktop Services

[] Volume Activation Services
4 @

4 [H] Web Server (18 of 34 installed)
[®] Commeon HTTP Features (5 of 6 installed)
[®] Health and Diagnostics (2 of 6 installed)
v/| Performance (Installed)
[m] Security (4 of @ installed)
[m] Application Development (5 of 11 installed)

[
b
P
P
4

| NE

w| .NET Extensibility 4.5 sta
[ Application Initialization
[ ase

[] ASP.NET35
w| ASPUNET 4.5 (Installed
O cal

] ISAP

w/| ISAPI Filters (Installed!

[ Server Side Includes

[] WebSocket Protocol
b [] FTP Server
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1.2  Step 2 - Set Up and Configure VETtrak ASP.NET API

In order for the API to run, a valid registration key for the VETtrak APl must be entered into the VETtrak
database using the VETtrak software, in File > Preferences > Registration Keys.

Obtain the VETtrak ASP.NET API ZIP file from VETtrak support. This can be downloaded from the Downloads
page in the Support Centre.

Before unzipping the ZIP file, right-click it and go to Properties. If there is an Unblock button on the General
tab, saying that the file has come from the internet, click the Unblock button followed by OK.

Extract the contents of the VETtrakAPI folder from within the VETtrak ASP.NET API ZIP file to a new folder on
the web server. It may be placed in a folder in the web root if desired, which by default is C:\inetpub\wwwroot.

Configure the API by editing the web.config file. This is an XML file that can be opened in a text editor. Find the
<connectionsStrings> element. Within this is an <add> element containing details of how to connect to the
>database. The <add> element must contain the following three attributes:

®  The name attribute must be “VETtrakDatabase”.

® TheproviderName attribute must be set to “FirebirdSgl.Data.FirebirdClient” if using a Firebird
database, or “System.Data.SglClient” if using a SQL Server database.

* The connectionString attribute is a standard connection string that defines the database server,
database filename (for Firebird) or database name (for SQL server), and the database username and
password. Examples follow.

The contents of the connectionString should be the same as VETtrak uses to connect to the database —
view these in VETtrak by going to File > Preferences > Database connection.

Note that, once the VETtrak API application is set up in 1IS, the connection string can be easily changed using
the Connection Strings icon in the application in [IS Manager — however, the providerName can only be
changed by editing the web.config file directly.

Firebird

If using a Firebird database, the add element and connection string should be in the format:

<add name="VETtrakDatabase" providerName="FirebirdSqgl.Data.FirebirdClient"
connectionString="User=<databaseUser>; Password=<databasePassword>;
Database=<pathAndFilenameOfDatabaseFileOnServer>;
DataSource=<serverNameOrIP>;Dialect=3;"/>

For example:

<add name="VETtrakDatabase" providerName="FirebirdSgl.Data.FirebirdClient"
connectionString="User=SYSDBA; Password=masterkey;Database=C:\Program Files
\VETtrak\Data\VETtrak.gdb;DataSource=192.168.0.40;Dialect=3;"/>

The components of the connectionString are:

® User — the Firebird username to connect to the database (not the username used to log into VETtrak). This
is almost always “SYSDBA”

* Password — the Firebird password to connect to the database (not the password used to log into VETtrak).
This is almost always “masterkey”

* Database — the full file path on the server to the database file (usually called VETtrak.gdb)

® Datasource — the IP address or resolvable name of the server that is running Firebird and on which the
database file is located

® Dialect - leave this as “3”

SQL Server with SQL server authentication

If using a SQL Server database, with SQL server authentication, the add element and connection string should
be in the format:

<add name="VETtrakDatabase" providerName="System.Data.SglClient"
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connectionString="Data Source=<serverNameOrIP>\<instanceName>;Initial
Catalog=<databaseName>;User Id=<databaseUser>;
Password=<databasePassword>;" />

For example:

<add name="VETtrakDatabase" providerName="System.Data.SglClient"
connectionString="Data Source=192.168.0.40\SQLEXPRESS;Initial
Catalog=VETtrak;User Id=sa;Password=sa;"/>

The components of the connectionString are:

® Datasource — the IP address or resolvable name of the server that is running SQL
Server, followed by a backslash and then the name of the SQL Server instance that
contains the VETtrak database

® 1Initial catalog— the name of the VETtrak database on that server and instance

® user 1d—the SQL Server username to connect to the database (not the username used
to log into VETtrak)

® rpassword —the SQL Server password to connect to the database (not the password
used to log into VETtrak)

SQL Server with Windows authentication

If using a SQL Server database, with Windows authentication, the add element and connection string should be
in the format:

<add name="VETtrakDatabase" providerName="System.Data.SglClient"
connectionString="Data Source=<serverNameOrIP>\<instanceName>;Initial
Catalog=<databaseName>; Integrated Security=true"/>

For example:

<add name="VETtrakDatabase" providerName="System.Data.SglClient"
connectionString="Data Source=192.168.0.40\SQLEXPRESS;Initial
Catalog=VETtrak; Integrated Security=true"/>

The components of the connectionString are:
® Datasource — the IP address or resolvable name of the server that is running SQL
Server, followed by a backslash and then the name of the SQL Server instance that
contains the VETtrak database
® 1Initial catalog— the name of the VETtrak database on that server and instance
® Integrated Security — leave this as “true” to use Windows Authentication

For Windows Authentication to work, the account set for the application pool identity (in the application pool’s
advanced settings) must have access to the VETtrak SQL Server database.

1.3  Step 3 - Adding an Application Pool

Open the IS Manager from Control Panel --> Administrative Tools --> Internet Information Services (IIS)
Manager.

It is recommended that the APIs be set up as an Application running within its own Application Pool. This
isolates the process and allows the APIs to be managed independently of other IIS applications running on the
server.

To do this, in the IIS Manager, click on Application Pools in the tree in the left panel, and click Add Application
Pool on the right.

© 2015 VETtrak Pty Ltd
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& Internet Information Services (I5) Manager i [} o ) i |
6@ |3 » ITCHY » Application Pools @~ @~

File View Help

| | @ Application Pool
» f pplication Pools
@ Admi
4 I"I"CHY ﬂfch_ drmir) This page lets you view and manage the list of application pools on the server. Application pocls are associated with
J Application Pools worker processes, contain one or more applications, and provide isolation among different applications.
a8 Sites
@ Default Web Site Filter: » [ Go - (g Show Al | Group by: Ne Grouping
Name Status NET Fram... Managed Pipel... Identity Applications
3 DefaultAppPool  Started w20 Integrated NetworkService 1

Ready

{3 |add Application Pool...

Set Application Pool Defaults..

® Hep

Online Help

In the Add Application Pool window, enter the following, followed by OK:
* Name: VETtrakAPIPool
* .NET Framework version: A version starting with “.NET Framework v2”

¢ Managed pipeline mode: Integrated

Start application pool immediately: Ticked

LB

Add Application Pocl

MName:

YETtrakAPIPool

MET Eramework version:

’.NEF Framework v2.0.50727 -

Managed pipeline mode:

’Integ:rated - ]

Start application pool immediately

J|

| ok P

This will add the Application Pool to the IIS Manager:
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— S
©5 Internet Information Services (IS) Manager - - lﬂlm
=l 2]
@ w | L » ITCHY » Application Pools | W @-
File View Help
— @ Application Pool :
o= Ication Fools
| i' pp & Add Application Pool... i
CE] Set Application Pool
e I'L'CHY Ry thdmin) This page lets you view and manage the list of application pools on the server. Application pools are associated with worker Defauﬁf&...
Lt Application Pools processes, contain one or more applications, and provide isolation amoeng different applications. e
a4 (@) Sites L = Application Pool Tasks
» @ Default Web Site Filter: v BHSe - g Show All | Group by: Mo Grouping F P Start
Name = Status NET Fram... Managed Pipel... Identity Applications B Stop
L2 DefaultAppPool Started  v2.0 Integrated MetworkService 5 £ Regycle..
L2} VETtrakAPIPool Started V2.0 Integrated ApplicationPoolldentity 0 | Edit Application Pool 5
D Basic Settings... T
Recycling...
Advanced Settings...
Rename
X Remove
View Applications
@ Help L 5
Content View Online Help -
Ready b
—

14  Step 4 - Add Application

In the left tree panel, under Sites, find the web site to add the VETtrak APIs to, such as the Default Web Site (a
new web site may be created first if desired). Right-click on this web site and click Add Application. Note that if
the VETtrak APIs were copied to a folder under the web root, it will already appear as a folder under the web site
(you may need to refresh in order to see it) — in this case, instead of adding the application, right-click on the
folder and select Convert to Application.

?3 Internet Information Services (IS} Manager l ==t
@C | @ » ITCHY » Sites » Default Web Site » | & = 5@ -
File View Help
= @ Default Web Site Home "
2 Explore
493 [TCHY (tchy\Admin) Grouplby:| Aves e Edit Permissions...
(2 Application Pools . - mp=
48] Sites os Edit Site
: : - — - Bindings...
@ Default Web Site N | S| - s L ; i
B Eplore 4 4= H o ':h j;" G,Eﬂ 1] Basic Settings...
Edit Permissions... :u Iv::mdil:'s R:TI: Logging  MIMETypes  Modules View Applications |
- Y pon.: View Virtual Directories 3
>  Add Application...
s Add Virtual Directory... Manage Web Site S
e Restart
Edit Bindings... ngs ; estarl
Manage Web Site » @ Stop
k3 Refresh Browse Web Site
% Remove [@] Browse *:B0 (hitp)
Rename Advanced Settings...
ontent View -
Switch to Content View ' Configure

In the Add Application window, enter the following, and click OK:

e Alias: This is what the URL to the APIs will be. This can be whatever you want. For the purposes of this
document, we will use “VETtrakAPI”

e Application pool: Click the Select button and choose the VETtrakAPIPool application pool from the list

* Physical path: Use the ... button to browse for and select the folder into which the VETtrak API ZIP was
extracted. For the purposes of this document, a path of “C:\VETtrakAPI” is used
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Within the new application, click the Content View button at the bottom to ensure you can

Add Application

Site name:  Default Web Site
Path: f

Pass-through authentication

| Connect as... | | Test Settings...

Alias: Application pool:
VETtrakAP] VETtrakAPIPool

Example: sales

Physical path:

kCAVETtrakaPI

oK

||

Cancel

for the API(s) you have, the web.config file and the bin folder containing the DLLs.

see the asmx file(s)

"j Internet Services (IIS) - - - - E@‘ﬁ
@’@ [ » [ICHY » Sites » Default WebSite » VETtrakAPL » & @ -
File View Help
| &) NVETtrakAPI Content =
] 15, 3 'VETtrakAPI' Tasks k=
& i o
45 r[,civ (TF‘hY\A“P’"":) Filter « Bfice - GhShow Al | Groupby: NoGrouging Applcation
-4} Application Pools - = = i
4] Sites iz Type Ej Switch to Features View
4 &) Default Web Site ~bin File Folder 4 Explore
ol !"é? VETtrakAPT = DatabaseMapping.xml XML Document Edit Permissions...
] VT_APLasm ASP.NET Web Service 3 Add Application...
Web.conf\g Borland Developer Studic Config File & Add Virtual Directory...
Manage Application @ |7
Browse
Advanced Settings...
& Refresh
x Remove
@ Help
Ready b
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1.5

Step 5 - Test that the VETtrak APl is Accessible

To test that the API is accessible, open an Internet Explorer browser, and enter the URL for the API:

http://host name/application name/VT APl.asmx

eg. For the example used in this document, the URL for the API will be:

http://localhost/VETtrakAPI/VT _APl.asmx

If everything is set up correctly, a service information page should appear, like the following:

13

T— . ~
D~ B3X

& hitp://localhost/VETtrakAPL/VT_APLasrmx

E VT_API Web Service ‘ ‘

The following operations are supported. For a formal definition, please review the|Service Description.

API Handshake
Checks the connection to the APT

AddClient
Creates a new client with the specified surname and given name

AddClientAfterCheck
Checks whether a client with the specified surname, given name and date of birth exists, and adds it if it doesn't exist

AddclientEvent
Adds a new client event

AddClientWebEnrolment
Enrols a client with the specified details into a new web enrolment linked to the specified occurrence 1D

AddClientWebReservation
Reserves a client with the specified details into the specified occurrence 1D

AddClientWebWaitlist
Adds a client to a waitlist for a programme

AddContactToEmployer
Attaches an existing client as a new contact for an employer

AddEmployerEvent
Adds a3 new employer event

AddEmployerWebEnrolment
Enrolz an employer with the specified details into a new web enrolment linked to the specified occurrence ID. Employees could then be added to this web
enrolment

AddEmployerWebReservation
Reserves an employer with the specified details into the specified occurrence ID. Employees could then be added to this web reservation

AddLMSClientEnrolmentToOccurrence
Enraols the client with the specified code into the LMS-enabled occurrence with the specified ID

Addl ooseWebEmployer
Creates a 'Loose' employer with the specified details for further use

1
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Click on the Service Description link to view the web service definition XML (WSDL):

[ - - P == (=] i

a | @ hitpi/localhost VETtrakAPUVT_APLasm?WSDL 0 = B 5 X || @ localhost ‘ ‘ oy

<?xml version="1.0" encoding="UTF-8"?>

<wsdl:definitions xmIns:wsdl="http://schemas.xmlsoap.org/wsdl/"
targetMamespace="http://www.ozsoft.com.au/VETtrak/api/complete"

| xmins:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmins:http="http:/ /schemas.xmlsoap.org/wsdl/http/"

xmins:tm="http://microsoft.com/wsdl/mime/textMatching/" xmins:scap="http://schemas.xmlsoap.org/wsdl/soap/"
xmins:tns="http://www.ozsoft.com.au/VETtrak/api/complete" xmIns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
xmins:soapl2="http://schemas.xmlsoap.org/wsdl/seap12/" xmins:s="http:/ /www.w3.org/2001/XMLSchema">
- =wsdl:types>
- «s:schema targetNamespace="http://www.ozsoft.com.au/VETtrak/api/complete" elementFormDefault="qualified">
- =s:element name="GetWaitlistProgrammeTypes">
- <s:complexType:
- <sisequencex
<s:element name="token" type="s:string" maxOccurs="1" minOccurs="0"/>
< /s:sequence=
</s:complexType:>
</s:element=
- =s:element name="GetWaitlistProgrammeTypesResponse" >
- <s:complexType>
- <5iSequence
<s:element name="GetWaitlistProgrammeTypesResult" type="tns:TAuthPrgtList" maxOccurs="1"
minOccurs="0"/>
=/5:sequence=
</s:complexType>
< /s element>
- <=s:complexType name="TAuthPrgtList":
- <s:complexContent mixed="false"=
- «s:extension base="tns:ReferenceListBaseOfTPrgt">
- <s:sequencex
<s:element name="PrgtList" type="tns:ArrayOfTPrgt" maxOccurs="1" minOccurs="0"/=
</sisequence>
</s:extension=
</s:complexContent=>
< /s:complexType=
- =s:complexType name="ReferencelistBaseOfTPrgt" abstract="true">
- <sisequUence>
<s:element name="Auth" type="tns:TAuthenticate" max0Occurs="1" minOccurs="0"/=>
</s:sequence:=
< /s:complexType=
- =<s:complexType name="TAuthenticate"> =

© 2015 VETtrak Pty Ltd
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To test the API's connectivity to the database, back on the Service Information page, click the DB_Handshake
link in the list:

|\§;‘ http://localhost/VETtrakAPYVT_APLasmx?op=DB_Handshake 0O ~ B = X

VT_API

Click here for a complete list of operations.

E VT_API Web Service | |

DB_Handshake

Checks the connection to the VETtrak database via the API

m

Test
To test the operation using the HTTP POST protocol, click the 'Invoke' button.

SOAP 1.1

The following is & sample SOAP 1.1 request and response. The placeholders shown need to be replaced with actual values.

BOST fJamEsAPIfVT_API.asmx HITE/1.1

Host: localhost

Content-Type: text/zml; charset=utf-8

Content-Length: length

SORPAction: "http://www.ozsoft.com.au/VETtrak/api/complete/DE_Handshake"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XML5chena—inatance” xmlns:xsd="http://www.w3.org/2001/XMLSchema™ xmlr
<soap:Body>
<DB_Handshake xmlns="http://www.ozsoft.com.au/VETtrak/api/complece” />
</soap:Body>
</soap:Envelope>

HITF/1.1 200 CK
Content-Type: text/zml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"7?>
<soap:Envelope xmlns:xsi="htcp://www.w3.org/2001/XML5chema-instance” xmlns:xsd="http://Wwww.w3.org/2001/XML5chema”™ Xmlr
<soap:Body>
<DB_HandshakesResponse xmlns="http://www.ozsoft.com.au/VETtrak/api/complete™>

- STD DWemdebhn kBl et nt i s IO Tomdebhin kBl e
4 i +
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16 Installing the ASP.NET VETtrak API onto IIS 7 or Later

Then click the Invoke button (by default, this button will only appear when using a browser on the same
machine the API is installed on, but this can be changed in the web.config file). The result should be an XML
string with a success message:

- . - SHACE X
| @ hitpy//localhost/VETtrakAPLVT_APLasm/DB_Handshake 0 ~ B X || @ localhost | ‘ vr B

<?xml version="1.0" encoding="UTF-8"?>
<string xmlins="http:/ /www.ozsoft.com.au/VETtrak/api/complete":=You are connected to the Database via the API.</string>

If the result is an error message, review the error and correct the connection string in the web.config file.

1.6  Step 6 - Test the VETtrak Enrol API with the Test Harness

You can use a test harness program to make web service calls to the API. With this, you can ensure that SOAP
calls to the API are working correctly.

To use the VETtrak API test harness, copy the VETtrakAPITestHarness.exe and
VETtrakAPITestHarness.exe.config files from the VETtrakAPITestHarness folder in the VETtrak ASP.NET API
ZIP file to a new folder (preferably on a different machine, which must have .NET Framework 3.5 installed).

) ‘o T N e e B g By “ew . EIEI—J
@\:‘j" . v Computer » O5(C) » TestVETtrakAPI - |&?| Search TestVETtrakd o]
Organize » Open Burn Mew folder 4= - E:l ':@'
. TestVETtrakAPI *  Name Date modified Type Size
) Users A .
VETtrak 27 VETtrakAPITestHarness.exe 4/07/2012 3:31 PM Application 660 KB
y tra
— i3 VETtrakAPITestHarness.exe. Config 24/10/201210:28 ... XML Configuratio... 2KB
] €l
J Windows i
.5 DVD RW Drive (D)

Double-click the VETtrakAPITestHarness.exe to run it.
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.

WLl VETtrak API Test Harness -_an | B | S

Connection
Server address (eg. http://152.168.1.1/VETtrak AP1/'VT_AP| asmoc)

. p 10:38:08
http:/Aocalhost/VE Tirak API/VT_AP| asmx B

GetPayment Types: Retrieved 5 payment types -

Usemame Password Token
N S— - 10:58:13
vettrak trakkcer $-78)8."7).)368382<2 GetClient EdtendedDetails: Retrieved details for client code 00525
Retrieved Data Stat Date  Retrieved Data End Date 2 enrolments, 3 contracts, 1 awards, 2 classes, 45 units, 12 events. F|
1/01/1900 Ew 31122100 B o

-

| Web Enrol | Cliernt | Staff | Employer | LMS Occurrence | Qualfication | Reference | Guery Data | SMS |

Client Code 00525 Given Test Sumame Person
| Find I Create | Details |M"ETMISS I Enrolments I Contracts I Awards | Classes/Attendance | Units/Results I Events I Staff | Invaices I Tasks |
Title Given name Sumame Other name Gender Update additional data
Mr Test Persan i
Date of Bith Email Emergency Contact Name
[¥]22/02/1981 +  here@there.com Mr Bloggs
Mobilz phone  Home phone  Work phone Fax phone Emergency Phone Address Type
0400112233 0366554433 0311223344 0395887766
Residential address Postal address
Address Address
25 There 5t 31 Here 5t
City Postcode  State City Postcode  State
Rouse Hil 2155 Rouse Hil 2155
Employer ldertfier Position Commenced Last assessed Teminated
35 2610202 - D2402012 ~ 24102012
Visa Mumber Visa Type Visa Expiry Passport number Salary
Buld XL
Usemame Password
ahmd1 353w ’ Update usemame/password

In the Server address field, enter the URL of the VT_APl.asmx. If you are running the test harness on the same
machine the API is installed on, this will be the same URL that was used in step 5. Click the Initialise button. If
this is successful, the button will change to Init OK.

Enter the Username and Password to access VETtrak (such as the default vettrak/trakker), and click the
Authenticate button. If successful, a token appears.

The other tabs and buttons can then be used to test various functions in the API. This includes:

* The Web Enrol tab for online enrolments, including loading and viewing web programmes and occurrences,
creating and updating clients and employer web enrolments, and recording payments

e The Client, Staff and Employer tabs for portals functionality, including viewing various details of clients,
staff members and employers, and updating some details

* The LMS Occurrence tab for LMS integration functionality, such as viewing and updating details of LMS
published occurrences and enrolments
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